Вход

Настройка IPTV на Openwrt
фев 03
Настройка IPTV на Openwrt

Решил по правильному настроить IPTV от своего провайдера. В интернете много разных описаний, но все они под конкретного провайдера. Я же предлагаю рассмотреть правильную настройку под любого провайдера. Итак, нам потребуется:

  1. Любой роутер, работающий под Openwrt
  2. Программа для доступа к роутеру в режиме терминала (я выбрал WinSCP)

Первым делом устанавливаем программу для просмотра IPTV. Делаем это через терминал (можно и через интерфейс luci):

opkg update
opkg install igmpproxy

1

Затем необходимо отредактировать файл конфигурации /etc/config/igmpproxy (удаляем всё из файла и заменяем на то, что ниже):

config igmpproxy
	option quickleave 1

config phyint
	option network wan
	option zone wan
	option direction upstream
#	list altnet 224.0.0.0/4

config phyint
	option network lan
	option zone lan
	option direction downstream

Обращаем внимание, что 'list altnet' закомментирована (#). В дальнейшем нам потребуется узнать нашу подсеть и прописать то что нужно.

Теперь надо разрешить трафик IGMP для wan интерфейса. Для этого редактируем файл /etc/config/firewall. Добавляем в конец файла записи:

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-IGMPPROXY'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'

Теперь через терминал проверим, разрешён ли у нас multicast. Для этого выполним команду:

cat /sys/devices/virtual/net/br-lan/bridge/multicast_snooping

2

Если ответ был 1, то ничего делать не надо. Если ответ был 0, то необходимо отредактировать файл /etc/config/network. В config interface 'lan' надо добавить строку: option igmp_snooping '1'

Теперь осталось перезапустить firewall и добавить igmpproxy в загрузку:

/etc/init.d/firewall restart
/etc/init.d/igmpproxy enable
/etc/init.d/igmpproxy start

После этого перезагружаем роутер и заходим в интерфейс luci. Нам необходимо понять какую подсеть для IPTV выдаёт наш провайдер. Для этого включаем приставку или подключаемся к IPTV иным способом (например через VLC). Заходим в логи роутера и ищем похожие строки:

3

Теперь возвращаемся к редактированию файла /etc/config/igmpproxy и удаляем знак комментария (#) в 'list altnet' и прописываем подсеть. В моём случае это list altnet 192.168.101.0/24. После этого останавливаем и запускаем igmpproxy и наслаждаемся IPTV.

/etc/init.d/igpmproxy stop
/etc/init.d/igpmproxy start

Заметки

Нет заметок для этой записи.